angel_seo 2.0.0

Dart native
Flutter Android iOS

Helper infrastructure for building SEO-friendly Web backends in Angel.

3
likes
80 / 110
pub points
36 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 4 API elements (75.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_seo/angel_seo.dart that imports:
  • package:angel_seo/src/inline_assets.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/inline_assets.dart:22:14

   ╷
22 │       return new Future<bool>.value(true);
   │              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/inline_assets.dart

INFO: Unnecessary new keyword.

lib/src/inline_assets.dart:42:5

   ╷
42 │     new _InlineAssets(vDir);
   │     ^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/inline_assets.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-alpha2.1.12.1.1
angel_static^2.0.0-alpha2.1.3+22.1.3+2
file^5.0.05.2.15.2.1
html^0.13.00.13.4+20.14.0+3
http_parser^3.0.03.1.43.1.4
path^1.0.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
async-2.4.22.4.2
charcode-1.1.31.1.3
code_buffer-1.0.11.0.1
collection-1.14.131.14.13
combinator-1.1.01.1.0
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.15.00.16.2
dart2_constant-1.0.2+dart21.0.2+dart2
http2-1.0.11.0.1
http_server-0.9.8+30.9.8+3
intl-0.16.10.16.1
matcher-0.12.90.12.9
merge_map-1.0.21.0.2
meta-1.2.31.2.3
mime-0.9.70.9.7
mock_request-1.0.71.0.7
quiver-2.1.32.1.3
quiver_hashcode-2.0.02.0.0
range_header-2.0.2+22.0.2+2
recase-2.0.13.0.0
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
utf-0.9.0+50.9.0+5
uuid-2.2.22.2.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.0` on html does not support the latest published version `0.14.0+3`

pubspec.yaml:12:9

   ╷
12 │   html: ^0.13.0
   │         ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
80
pub points
36%
popularity

Publisher

angel-dart.dev

Helper infrastructure for building SEO-friendly Web backends in Angel.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_framework, angel_static, file, html, http_parser, path

More

Packages that depend on angel_seo