angel_proxy 2.2.0
angel_proxy: ^2.2.0 copied to clipboard

Angel middleware to forward requests to another server (i.e. pub serve).

0
likes
90 / 130
pub points
39 %
popularity

We analyzed this package on Jun 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 13 API elements (53.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_proxy/angel_proxy.dart that imports:
  • package:angel_proxy/src/proxy_layer.dart that imports:
  • package:angel_framework/http.dart that imports:
  • package:angel_framework/src/http/http.dart that imports:
  • package:angel_framework/src/http/http_response_context.dart that imports:
  • package:angel_framework/src/http/http_request_context.dart that imports:
  • package:angel_framework/src/core/core.dart that imports:
  • package:angel_framework/src/core/service.dart that imports:
  • package:angel_framework/src/core/server.dart that imports:
  • package:angel_framework/src/core/routable.dart that imports:
  • package:angel_framework/src/core/response_context.dart that imports:
  • package:angel_framework/src/core/request_context.dart that imports:
  • package:http_server/http_server.dart that imports:
  • package:http_server/src/http_multipart_form_data.dart that imports:
  • package:http_server/src/http_multipart_form_data_impl.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-alpha2.1.12.1.1
http^0.12.00.12.20.13.3
http_parser^3.0.03.1.44.0.0
path^1.0.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
charcode-1.3.11.3.1
clock-1.1.01.1.0
code_buffer-1.0.11.0.1
collection-1.15.01.15.0
combinator-1.1.01.1.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.16.1.2
http2-1.0.12.0.0
http_server-0.9.8+31.0.0
intl-0.17.00.17.0
matcher-0.12.100.12.10
merge_map-1.0.21.0.2
meta-1.4.01.4.0
mime-0.9.71.0.0
quiver-2.1.53.0.1
quiver_hashcode-2.0.03.0.0+1
recase-2.0.14.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^3.0.0` on http_parser does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions http_parser to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Dart 2.13.1.

0
likes
90
pub points
39%
popularity

Publisher

angel-dart.dev

Angel middleware to forward requests to another server (i.e. pub serve).

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_framework, http, http_parser, path

More

Packages that depend on angel_proxy