angel_mongo 2.0.3

Dart native
Flutter Android iOS

MongoDB-enabled services for the Angel framework. Well-tested.

1
likes
80 / 110
pub points
58 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 26 API elements (73.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_mongo/angel_mongo.dart that imports:
  • package:angel_mongo/services.dart that imports:
  • package:mongo_dart/mongo_dart.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: Don't type annotate initializing formals.

lib/mongo_service.dart:19:16

   ╷
19 │   MongoService(DbCollection this.collection,
   │                ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/mongo_service.dart

INFO: Unnecessary new keyword.

lib/mongo_service.dart:24:18

   ╷
24 │     Map params = new Map.from(params_ ?? {});
   │                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/mongo_service.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-alpha2.1.12.1.1
json_god>=2.0.0-beta <3.0.02.0.0-beta+31.0.1
merge_map^1.0.01.0.21.0.2
mongo_dart>=0.2.7 <1.0.00.4.30.4.3
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
asn1lib-0.6.50.7.0
async-2.4.22.4.2
basic_utils-2.6.22.6.2
bson-0.3.30.3.3
charcode-1.1.31.1.3
code_buffer-1.0.11.0.1
collection-1.14.131.14.13
combinator-1.1.01.1.0
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.15.2.1
fixnum-0.10.110.10.11
http2-1.0.01.0.0
http_parser-3.1.43.1.4
http_server-0.9.8+30.9.8+3
intl-0.16.10.16.1
json_annotation-3.0.13.0.1
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.31.2.3
mime-0.9.70.9.7
mock_request-1.0.71.0.7
mongo_dart_query-0.4.20.4.2
more-1.18.22.7.0
path-1.7.01.7.0
pointycastle-1.0.21.0.2
pool-1.4.01.4.0
quiver-2.1.32.1.3
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.0
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
tuple-1.0.31.0.3
typed_data-1.2.01.2.0
uuid-2.2.22.2.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.0.0-beta <3.0.0` on json_god does not support the latest published version `1.0.1`

pubspec.yaml:10:13

   ╷
10 │   json_god: ">=2.0.0-beta <3.0.0"
   │             ^^^^^^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
80
pub points
58%
popularity

Publisher

angel-dart.dev

MongoDB-enabled services for the Angel framework. Well-tested.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_framework, json_god, merge_map, mongo_dart

More

Packages that depend on angel_mongo