angel_cli 2.1.7+1

Dart native

Command-line tools for the Angel framework, including scaffolding.

1
likes
80 / 110
pub points
19 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 67 API elements (29.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_cli/angel_cli.dart that imports:
  • package:angel_cli/src/commands/commands.dart that imports:
  • package:angel_cli/src/commands/rename.dart that imports:
  • package:angel_cli/src/commands/pub.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 178 issues. Showing the first 2:

INFO: Unnecessary new keyword.

bin/angel.dart:12:16

   ╷
12 │     var runner = new CommandRunner(
   │ ┌────────────────^
13 │ │       "angel",
14 │ │       asciiArt.trim() +
15 │ │           '\n\n' +
16 │ │           "Command-line tools for the Angel framework." +
17 │ │           '\n\n' +
18 │ │           'https://angel-dart.github.io');
   │ └─────────────────────────────────────────^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/angel.dart

INFO: Unnecessary new keyword.

bin/angel.dart:24:18

   ╷
24 │     ..addCommand(new DeployCommand())
   │                  ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/angel.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.32.0 <2.0.00.39.100.40.3
args^1.0.01.6.01.6.0
code_builder^3.0.03.4.13.4.1
dart_style^1.0.01.3.61.3.7
glob^1.1.01.2.01.2.0
http^0.12.00.12.20.12.2
inflection2^0.4.20.4.30.4.3
io^0.3.20.3.40.3.4
mustache4dart^3.0.0-dev.1.03.0.0-dev.1.02.1.2
path^1.0.01.7.01.7.0
prompts^1.0.01.3.11.3.1
pubspec_parse^0.1.20.1.50.1.5
quiver^2.0.02.1.32.1.3
recase^2.0.02.0.13.0.0
shutdown^0.4.00.4.20.4.2
watcher^0.9.70.9.7+150.9.7+15
yaml^2.0.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-4.0.010.0.0
async-2.4.22.4.2
build-1.3.01.5.0
build_config-0.4.20.4.2
build_daemon-2.1.42.1.4
build_resolvers-1.3.91.4.1
build_runner-1.10.01.10.3
build_runner_core-5.2.06.0.2
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
fixnum-0.10.110.10.11
graphs-0.2.00.2.0
html-0.14.0+30.14.0+3
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
js-0.6.20.6.2
json_annotation-3.1.03.1.0
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.31.2.3
mime-0.9.70.9.7
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
pedantic-1.9.21.9.2
pool-1.4.01.4.0
pub_semver-1.4.41.4.4
reflectable-2.2.52.2.5
shelf-0.7.90.7.9
shelf_web_socket-0.2.30.2.3
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
stream_channel-2.0.02.0.0
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
timing-0.1.1+20.1.1+2
typed_data-1.2.01.2.0
web_socket_channel-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0-dev.1.0` on mustache4dart does not support the latest published version `2.1.2`

pubspec.yaml:15:18

   ╷
15 │   mustache4dart: ^3.0.0-dev.1.0
   │                  ^^^^^^^^^^^^^^
   ╵
The constraint `^2.0.0` on recase does not support the latest published version `3.0.0`

pubspec.yaml:20:11

   ╷
20 │   recase: ^2.0.0
   │           ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs