android_intent_plus 5.0.2 copy "android_intent_plus: ^5.0.2" to clipboard
android_intent_plus: ^5.0.2 copied to clipboard

PlatformAndroid

Flutter plugin for launching Android Intents. Not supported on iOS.

371
likes
160/ 160
pub points
99%
popularity

We analyzed this package 2 days ago, and awarded it 160 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://plus.fluttercommunity.dev/ was unreachable. Make sure that the website is reachable via HEAD requests.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/fluttercommunity/plus_plugins/labels/android_intent_plus was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

52 out of 54 API elements (96.3 %) have documentation comments.

Some symbols that are missing documentation: android_intent, flag.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:android_intent_plus/android_intent.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:android_intent_plus/android_intent.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:android_intent_plus/android_intent.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:android_intent_plus/android_intent.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:android_intent_plus/android_intent.dart that declares support for platforms: Android.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
meta ^1.8.0 1.12.0 1.15.0
platform ^3.1.0 3.1.5 3.1.5
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

371
likes
160
pub points
99%
popularity

Publisher

verified publisherfluttercommunity.dev

Flutter plugin for launching Android Intents. Not supported on iOS.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

flutter, meta, platform

More

Packages that depend on android_intent_plus