analyzer 0.39.15
analyzer: ^0.39.15 copied to clipboard

This package provides a library that performs static analysis of Dart code.

69
likes
70 / 130
pub points
99 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 2880 out of 5032 API elements (57.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:analyzer/analyzer.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/util/comment.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/fasta/ast_builder.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
Because analyzer depends on analysis_tool from path which doesn't exist (could not find package analysis_tool at "../analysis_tool"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.