analyzer 0.33.3+2

Dart native
Flutter Android iOS

Static analyzer for Dart.

30
likes
35 / 100
pub points
99 %
popularity

We analyzed this package on Sep 13, 2020, and awarded it 35 pub points (of a possible 100):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:38:32

   ╷
38 │ <p>Check out all the available <a href="http://dart-lang.github.io/linter/lints/">Dart lint rules</a>.</p>
   │                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 10

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:analyzer/analyzer.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/task/dart.dart that imports:
  • package:analyzer/src/task/strong_mode.dart that imports:
  • package:analyzer/src/summary/link.dart that imports:
  • package:analyzer/src/summary/resynthesize.dart that imports:
  • package:analyzer/src/summary/summary_sdk.dart that imports:
  • package:analyzer/src/summary/package_bundle_reader.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/task/model.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io
Pass static analysis
10 / 30

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 13165 issues. Showing the first 2:

WARNING: Parameters can't override default values, this method overrides 'ContextLocator.locateContexts' where 'excludedPaths' has a different value.

lib/src/dart/analysis/context_locator.dart:74:7

   ╷
74 │       List<String> excludedPaths: null,
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/dart/analysis/context_locator.dart

INFO: Use `=` to separate a named parameter from its default value.

lib/analyzer.dart:40:38

   ╷
40 │     {String name, bool suppressErrors: false, bool parseFunctionBodies: true}) {
   │                                      ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/analyzer.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args>=0.12.1 <2.0.01.6.01.6.0
charcode^1.1.01.1.31.1.3
collection^1.10.11.14.131.14.13
convert^2.0.02.1.12.1.1
crypto>=1.1.1 <3.0.02.1.52.1.5
front_end0.1.6+50.1.6+50.1.29
glob^1.0.31.2.01.2.0
html>=0.12.0 <1.14.00.14.0+30.14.0+3
kernel0.3.6+50.3.6+50.3.29
meta^1.0.21.2.31.2.3
package_config>=0.1.5 <2.0.01.9.31.9.3
path>=0.9.0 <2.0.01.7.01.7.0
plugin^0.2.00.2.0+30.2.0+3
source_span^1.2.01.7.01.7.0
watcher>=0.9.6 <0.10.00.9.7+150.9.7+15
yaml^2.1.22.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
csslib-0.16.20.16.2
js-0.6.20.6.2
logging-0.11.40.11.4
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
pedantic-1.9.21.9.2
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `0.1.6+5` on front_end does not support the latest published version `0.1.29`

pubspec.yaml:14:14

   ╷
14 │   front_end: 0.1.6+5
   │              ^^^^^^^
   ╵
The constraint `0.3.6+5` on kernel does not support the latest published version `0.3.29`

pubspec.yaml:17:11

   ╷
17 │   kernel: 0.3.6+5
   │           ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs