airbridge_flutter_sdk 3.1.0 icon indicating copy to clipboard operation
airbridge_flutter_sdk: ^3.1.0 copied to clipboard

Airbridge SDK for Flutter.

3
likes
110/ 140
pub points
82%
popularity

We analyzed this package 2 hours ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 111 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:airbridge_flutter_sdk/airbridge_flutter_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:airbridge_flutter_sdk/airbridge_flutter_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:airbridge_flutter_sdk/airbridge_flutter_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:airbridge_flutter_sdk/airbridge_flutter_sdk.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

lib/src/airbridge.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/data/event_option.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
collection-1.17.01.17.1
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

3
likes
110
pub points
82%
popularity

Publisher

verified publisher iconairbridge.io

Airbridge SDK for Flutter.

Homepage

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on airbridge_flutter_sdk