agent_dart_auth 0.0.2 icon indicating copy to clipboard operation
agent_dart_auth: ^0.0.2 copied to clipboard

A new flutter plugin project.

0
likes
100/ 140
pub points
53%
popularity

We analyzed this package 23 hours ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 14 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:agent_dart_auth/agent_dart_auth.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Windows`.

Because:

  • package:agent_dart_auth/agent_dart_auth.dart that imports:
  • package:flutter_web_auth/flutter_web_auth.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:agent_dart_auth/agent_dart_auth.dart that imports:
  • package:flutter_web_auth/flutter_web_auth.dart that declares support for platforms: Android, iOS, macOS, Web.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Unused import: 'dart:typed_data'.

lib/agent_dart_auth.dart:4:8

  ╷
4 │ import 'dart:typed_data';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/agent_dart_auth.dart

lib/webauth_provider.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
agent_dart>=0.1.13 <1.0.00.1.24+10.1.24+1
flutterflutter0.0.00.0.0
flutter_web_auth^0.3.00.3.20.5.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.3.63.3.6
args-2.3.22.3.2
async-2.10.02.10.0
basic_utils-4.5.25.4.2
bip32-2.0.02.0.0
bip39-1.0.61.0.6
bs58check-1.0.21.0.2
cbor-4.1.05.1.2
characters-1.2.11.2.1
collection-1.17.01.17.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
ffi-1.2.12.0.1
fixnum-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
hex-0.2.00.2.0
http-0.13.50.13.5
http_parser-4.0.24.0.2
js-0.6.50.6.7
json_annotation-4.8.04.8.0
logging-1.1.11.1.1
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
path-1.8.31.8.3
pinenacl-0.3.40.5.1
pointycastle-3.6.23.6.2
protobuf-2.1.02.1.0
recase-4.1.04.1.0
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
tuple-2.0.12.0.1
typed_data-1.3.11.3.1
uuid-3.0.73.0.7
validators-3.0.03.0.0
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.0` on flutter_web_auth does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions flutter_web_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.