advance_pdf_viewer_fork 2.0.0 copy "advance_pdf_viewer_fork: ^2.0.0" to clipboard
advance_pdf_viewer_fork: ^2.0.0 copied to clipboard

A flutter plugin for handling PDF files. Works on both Android & iOS

28
likes
140/ 160
pub points
93%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

29 out of 84 API elements (34.5 %) have documentation comments.

Some symbols that are missing documentation: advance_pdf_viewer_fork, advance_pdf_viewer_fork.CustomZoomableWidget, advance_pdf_viewer_fork.CustomZoomableWidget.CustomZoomableWidget, advance_pdf_viewer_fork.IndicatorPosition, advance_pdf_viewer_fork.PDFDocument.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:advance_pdf_viewer_fork/advance_pdf_viewer_fork.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:advance_pdf_viewer_fork/advance_pdf_viewer_fork.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:advance_pdf_viewer_fork/advance_pdf_viewer_fork.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:advance_pdf_viewer_fork/advance_pdf_viewer_fork.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 30 issues. Showing the first 2:

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: PDFListViewer._images, PDFListViewer._loadingPageHeight

lib/src/list_viewer.dart:4:7

  ╷
4 │ class PDFListViewer extends StatefulWidget {
  │       ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/list_viewer.dart

WARNING: Unused import: 'dart:ui'.

lib/src/page.dart:2:8

  ╷
2 │ import 'dart:ui';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/page.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_cache_manager ^3.1.1 3.3.2 3.3.2
numberpicker ^2.1.1 2.1.2 2.1.2
path_provider ^2.0.2 2.1.3 2.1.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.1.0
infinite_listview - 1.1.0 1.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.7 2.2.7
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
rxdart - 0.27.7 0.28.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite - 2.3.3+1 2.3.3+1
sqflite_common - 2.5.4 2.5.4
string_scanner - 1.3.0 1.3.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.2 4.4.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

28
likes
140
pub points
93%
popularity

Publisher

unverified uploader

A flutter plugin for handling PDF files. Works on both Android & iOS

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

flutter, flutter_cache_manager, numberpicker, path_provider

More

Packages that depend on advance_pdf_viewer_fork