advance_pdf_viewer 2.0.1 copy "advance_pdf_viewer: ^2.0.1" to clipboard
advance_pdf_viewer: ^2.0.1 copied to clipboard

discontinuedreplaced by: pdfx
PlatformAndroidiOS

A flutter plugin for handling PDF files. Works on both Android & iOS

350
likes
120/ 140
pub points
96%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

131 out of 228 API elements (57.5 %) have documentation comments.

Some symbols that are missing documentation: advance_pdf_viewer, advance_pdf_viewer.CacheManager.CacheManager.custom, advance_pdf_viewer.CacheManager.logLevel, advance_pdf_viewer.CacheObjectProvider, advance_pdf_viewer.CacheObjectProvider.databaseName.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:advance_pdf_viewer/advance_pdf_viewer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:advance_pdf_viewer/advance_pdf_viewer.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:advance_pdf_viewer/advance_pdf_viewer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:advance_pdf_viewer/advance_pdf_viewer.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

WARNING: This API is available since SDK 2.14.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/src/document.dart:156:30

    ╷
156 │   int get hashCode => Object.hash(_filePath, count);
    │                              ^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/document.dart

INFO: The import of 'package:flutter/painting.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/widgets.dart'.

lib/src/page.dart:4:8

  ╷
4 │ import 'package:flutter/painting.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/page.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_cache_manager ^3.3.0 3.3.1 3.3.1
numberpicker ^2.1.1 2.1.2 2.1.2
path_provider ^2.0.8 2.1.3 2.1.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
infinite_listview - 1.1.0 1.1.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
rxdart - 0.27.7 0.27.7
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite - 2.3.3 2.3.3
sqflite_common - 2.5.4 2.5.4
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

350
likes
120
pub points
96%
popularity

Publisher

verified publisherdlohani.com.np

A flutter plugin for handling PDF files. Works on both Android & iOS

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, flutter_cache_manager, numberpicker, path_provider

More

Packages that depend on advance_pdf_viewer