addu_sis 1.0.1
addu_sis: ^1.0.1 copied to clipboard

A Dart library for accessing AdDU Student Information System (SIS) data. Originally built for AdDU Hub Flutter app.

1
likes
65 / 110
pub points
0 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:57:11

   ╷
57 │ <p>We use <a href="http://semver.org/">SemVer</a> for versioning. For the versions available, see the <a href="https://github.com/sonroyaalmerol/dart-addu-sis/tags">tags on this repository</a>.</p>
   │           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/addu_sis_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 9 API elements (11.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:addu_sis/addu_sis.dart that imports:
  • package:addu_sis/src/SIS.dart that imports:
  • package:cookie_jar/cookie_jar.dart that imports:
  • package:cookie_jar/src/serializable_cookie.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

lib/src/SIS.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/models/Balance.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cookie_jar^1.0.01.0.13.0.1
dio^3.0.93.0.104.0.0
dio_cookie_manager^1.0.01.0.02.0.0
html^0.14.0+30.14.0+40.15.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
csslib-0.16.20.17.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.0.0` on cookie_jar does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cookie_jar to update the constraint.

The constraint `^3.0.9` on dio does not support the stable version `4.0.0`, that was published 15 days ago.

When dio is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

1
likes
65
pub points
0%
popularity

Publisher

snry.xyz

A Dart library for accessing AdDU Student Information System (SIS) data. Originally built for AdDU Hub Flutter app.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cookie_jar, dio, dio_cookie_manager, html

More

Packages that depend on addu_sis