absinthe_socket 0.0.3

Flutter Android iOS

A GraphQL subscription client for Absinthe sockets.

2
likes
45 / 110
pub points
73 %
popularity

We analyzed this package on Sep 17, 2020, and awarded it 45 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:2:48

  ╷
2 │ <p>A dart client for GraphQL subscriptions via <a href="http://absinthe-graphql.org/">Absinthe</a> sockets</p>
  │                                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 64 API elements (1.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
phoenix_wings^0.1.30.1.30.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3` on phoenix_wings does not support the latest published version `0.2.1`

pubspec.yaml:12:18

   ╷
12 │   phoenix_wings: ^0.1.3
   │                  ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

2
likes
45
pub points
73%
popularity

A GraphQL subscription client for Absinthe sockets.

Repository
View/report issues

Documentation

API reference

Uploader

josh@smoothterminal.com

License

MIT (LICENSE)

Dependencies

phoenix_wings

More

Packages that depend on absinthe_socket