about 1.2.0

Flutter Android iOS

Displays an About dialog, which describes the application, can show licenses, changelog, and other information.

14
likes
100 / 110
pub points
82 %
popularity

We analyzed this package on Aug 14, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 82 out of 84 API elements (97.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:about/about.dart that imports:
  • package:about/src/markdown_list_title.dart that imports:
  • package:about/src/markdown.dart that imports:
  • package:about/src/template.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:about/about.dart that imports:
  • package:about/src/markdown_list_title.dart that imports:
  • package:about/src/markdown.dart that imports:
  • package:about/src/template.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS
Package does not support Flutter platform Linux

Because:

  • package:about/about.dart that imports:
  • package:about/src/markdown_list_title.dart that imports:
  • package:about/src/markdown.dart that imports:
  • package:about/src/template.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_markdown>=0.3.5 <1.0.00.4.30.4.3
markdown^2.1.12.1.72.1.7
package_info>=0.4.0 <2.0.00.4.10.4.1
path^1.6.01.7.01.7.0
pedantic^1.8.01.9.01.9.2
simple_mustache^1.0.01.0.01.0.0
url_launcher^5.1.05.5.05.5.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
flutter_web_plugins-0.0.00.0.0
meta-1.1.81.2.2
platform_detect-1.4.01.4.0
plugin_platform_interface-1.0.21.0.2
pub_semver-1.4.41.4.4
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
url_launcher_linux-0.0.1+10.0.1+1
url_launcher_macos-0.0.1+70.0.1+7
url_launcher_platform_interface-1.0.71.0.7
url_launcher_web-0.1.2+10.1.2+1
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

14
likes
100
pub points
82%
popularity

Publisher

nfet.net

Displays an About dialog, which describes the application, can show licenses, changelog, and other information.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

flutter, flutter_markdown, markdown, package_info, path, pedantic, simple_mustache, url_launcher

More

Packages that depend on about