about 1.0.0

About #

Displays an About dialog, which describes the application.

Usage #

To use this plugin, add about as a dependency in your pubspec.yaml file.

Example #

showAboutPage(
  applicationLegalese: 'Copyright © David PHAM-VAN, {{ year }}',
  applicationDescription:
      Text('Displays an About dialog, which describes the application.'),
  children: <Widget>[
    MarkdownPageListTile(
      icon: Icon(Icons.list),
      title: Text('Changelog'),
      filename: 'CHANGELOG.md',
    ),
    LicensesPageListTile(
      icon: Icon(Icons.favorite),
    ),
  ],
  applicationIcon: SizedBox(
      width: 100,
      height: 100,
      child: Image(image: const AssetImage('assets/icon.webp'))),
)

1.0.0 #

  • First version

example/README.md

About #

Displays an About dialog, which describes the application.

Usage #

To use this plugin, add about as a dependency in your pubspec.yaml file.

Example #

showAboutPage(
  applicationLegalese: 'Copyright © David PHAM-VAN, {{ year }}',
  applicationDescription:
      Text('Displays an About dialog, which describes the application.'),
  children: <Widget>[
    MarkdownPageListTile(
      icon: Icon(Icons.list),
      title: Text('Changelog'),
      filename: 'CHANGELOG.md',
    ),
    LicensesPageListTile(
      icon: Icon(Icons.favorite),
    ),
  ],
  applicationIcon: SizedBox(
      width: 100,
      height: 100,
      child: Image(image: const AssetImage('assets/icon.webp'))),
)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  about: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:about/about.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Jul 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/src/licenses.dart.

Run flutter format to format lib/src/licenses.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/DavBfr/flutter_about was unreachable.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
flutter 0.0.0
flutter_markdown ^0.2.0 0.2.0
package_info ^0.4.0 0.4.0+5
path ^1.6.0 1.6.2
url_launcher ^5.0.0 5.1.0
Transitive dependencies
args 1.5.2
charcode 1.1.2
collection 1.14.11
markdown 2.0.3
meta 1.1.6 1.1.7
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin