zwave 0.10.0
zwave: ^0.10.0 copied to clipboard

A Dart Library for interacting with Z-Wave devices on Linux.

0
likes
65 / 130
pub points
0 %
popularity

We analyzed this package on Jun 18, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:17:1

   ╷
17 │ <a href="http://aeotec.com/z-wave-usb-stick">Aeon Labs Aeotec Z-Wave Z-Stick, Gen5 (ZW090)</a>.</li>
   │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 179 out of 1397 API elements (12.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:zwave/port/rpi_zw_port.dart that imports:
  • package:zwave/port/zw_port.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

bin/decode_packet.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/capability/switch_binary.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
logging^0.11.30.11.41.0.1
path^1.6.41.8.01.8.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.11.3` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.3.

0
likes
65
pub points
0%
popularity

Publisher

Unknown

A Dart Library for interacting with Z-Wave devices on Linux.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

logging, path

More

Packages that depend on zwave