zwap_utils 0.0.42
zwap_utils: ^0.0.42 copied to clipboard

A Flutter library to handle Util functions in any Zwap projects

0
likes
100/ 130
pub points
48%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 106 out of 136 API elements (77.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:zwap_utils/zwap_utils.dart that imports:
  • package:zwap_utils/zwap_utils/api/apiService.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

lib/zwap_utils.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/zwap_utils/api/apiService.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
get_it^7.1.37.2.07.2.0
http^0.13.30.13.40.13.4
quiver^3.0.13.0.1+13.0.1+1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

0
likes
100
pub points
48%
popularity

A Flutter library to handle Util functions in any Zwap projects

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_web_plugins, get_it, http, quiver

More

Packages that depend on zwap_utils