xxim_core_flutter 1.0.2 copy "xxim_core_flutter: ^1.0.2" to clipboard
xxim_core_flutter: ^1.0.2 copied to clipboard

Xingxing is a 100% open source social platform, where everyone can build their own server and control the ownership of data.

1
likes
140/ 160
pub points
4%
popularity

We analyzed this package 16 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1642 out of 2438 API elements (67.4 %) have documentation comments.

Some symbols that are missing documentation: xxim_core_flutter, xxim_core_flutter.AckNoticeDataReq, xxim_core_flutter.AckNoticeDataReq.$_whichOneof, xxim_core_flutter.AckNoticeDataReq.AckNoticeDataReq, xxim_core_flutter.AckNoticeDataReq.check.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/src/proto/core.pb.dart:1:1

  ╷
1 │ ///
  │ ^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/proto/core.pb.dart

INFO: Dangling library doc comment.

lib/src/proto/core.pbenum.dart:1:1

  ╷
1 │ ///
  │ ^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/proto/core.pbenum.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
crypto ^3.0.3 3.0.3 3.0.3
encrypt ^5.0.1 5.0.3 5.0.3
flutter flutter 0.0.0 0.0.0
protobuf ^2.1.0 2.1.0 3.1.0
web_socket_channel ^2.4.0 2.4.5 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
convert - 3.1.1 3.1.1
fixnum - 1.1.0 1.1.0
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
pointycastle - 3.9.1 3.9.1
sky_engine - 0.0.99 0.0.99
stream_channel - 2.1.2 2.1.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.0` on protobuf does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

The constraint `^2.4.0` on web_socket_channel does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions web_socket_channel to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
140
pub points
4%
popularity

Publisher

verified publishercherish.chat

Xingxing is a 100% open source social platform, where everyone can build their own server and control the ownership of data.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

crypto, encrypt, flutter, protobuf, web_socket_channel

More

Packages that depend on xxim_core_flutter