xpath_selector_html_parser 3.0.1 icon indicating copy to clipboard operation
xpath_selector_html_parser: ^3.0.1 copied to clipboard

A html parser implementation with html for xpath_selector, xpath_selector is required.

0
likes
140/ 140
pub points
75%
popularity

We analyzed this package 4 days ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 14 out of 21 API elements (66.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
html^0.15.10.15.10.15.1
xpath_selector^3.0.23.0.23.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
clock-1.1.11.1.1
collection-1.17.11.17.1
csslib-0.17.20.17.2
expressions-0.2.50.2.5
fake_async-1.3.11.3.1
matcher-0.12.140.12.14
meta-1.9.01.9.0
path-1.8.31.8.3
petitparser-5.1.05.1.0
quiver-3.2.13.2.1
rxdart-0.27.70.27.7
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
term_glyph-1.2.11.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.1.

0
likes
140
pub points
75%
popularity

Publisher

verified publisher iconz31.ink

A html parser implementation with html for xpath_selector, xpath_selector is required.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

html, xpath_selector

More

Packages that depend on xpath_selector_html_parser