x509csr 1.0.2

Dart native js
Flutter Android iOS web

Create X.509 Certificate Signing Requests, plus associated PEM helper functions.

0
likes
90 / 110
pub points
69 %
popularity

We analyzed this package on Sep 29, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/x509csr.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 12 API elements (75.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 26 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/crypto.dart:21:7

   ╷
21 │       new RSAKeyGeneratorParameters(BigInt.parse('65537'), bitStrength, 12);
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/crypto.dart

INFO: Unnecessary new keyword.

lib/crypto.dart:23:22

   ╷
23 │   var secureRandom = new FortunaRandom();
   │                      ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/crypto.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
asn1lib^0.5.70.5.150.8.1
pointycastle^1.0.11.0.21.0.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.7` on asn1lib does not support the latest published version `0.8.1`

pubspec.yaml:11:12

   ╷
11 │   asn1lib: ^0.5.7
   │            ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
69%
popularity

Create X.509 Certificate Signing Requests, plus associated PEM helper functions.

Homepage

Documentation

API reference

Uploader

davidjanes@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

asn1lib, pointycastle

More

Packages that depend on x509csr