wsgrpc 0.0.1

A new flutter package project.

0
likes
10 / 110
pub points
0 %
popularity

We analyzed this package on Sep 26, 2020, and awarded it 10 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Sdk-constraint doesn't allow future stable dart 2.x releases

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=1.8.0 <=2.1.0"
  │        ^^^^^^^^^^^^^^^^^
  ╵
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 264 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:protobuf/protobuf.dart'.

lib/generated/wsgrpc.pb.dart:9:8

  ╷
9 │ import 'package:protobuf/protobuf.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/generated/wsgrpc.pb.dart

ERROR: Classes can only extend other classes.

lib/generated/wsgrpc.pb.dart:15:33

   ╷
15 │ class DataFrame_Headers extends GeneratedMessage {
   │                                 ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/generated/wsgrpc.pb.dart

Support up-to-date dependencies
0 / 20

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 2.9.3. Cannot run `pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=1.8.0 <=2.1.0"
  │        ^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

The current sdk constraint does not allow the latest stable Dart (2.9.3)

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=1.8.0 <=2.1.0"
  │        ^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (2.9.2)

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=1.8.0 <=2.1.0"
  │        ^^^^^^^^^^^^^^^^^
  ╵
0
likes
10
pub points
0%
popularity

A new flutter package project.

Homepage

Uploader

tsangpozheng@gmail.com

License

unknown (LICENSE)

More

Packages that depend on wsgrpc