wordpress_client 5.3.1
wordpress_client: ^5.3.1 copied to clipboard

A library written purely in dart to interact with Wordpress REST API in a fluent manner. Supports Authorization as well.

2
likes
100/ 130
pub points
57%
popularity

We analyzed this package on Oct 25, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/wordpress_client_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 64 out of 428 API elements (15.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:wordpress_client/wordpress_client.dart that imports:
  • package:wordpress_client/src/internal_requester.dart that imports:
  • package:dio_cookie_manager/dio_cookie_manager.dart that imports:
  • package:dio_cookie_manager/src/cookie_mgr.dart that imports:
  • package:cookie_jar/cookie_jar.dart that imports:
  • package:cookie_jar/src/file_storage.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 26 issues. Showing the first 2:

lib/src/authorization/authorization_methods/basic_auth.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/authorization/authorization_methods/basic_jwt.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cookie_jar^3.0.13.0.13.0.1
dio^4.0.04.0.14.0.1
dio_cache_interceptor^3.0.23.0.23.0.2
dio_cookie_manager^2.0.02.0.02.0.0
http_parser^4.0.04.0.04.0.0
path^1.8.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Dart 2.14.3.

2
likes
100
pub points
57%
popularity

A library written purely in dart to interact with Wordpress REST API in a fluent manner. Supports Authorization as well.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cookie_jar, dio, dio_cache_interceptor, dio_cookie_manager, http_parser, path

More

Packages that depend on wordpress_client