wired2 0.1.0
wired2: ^0.1.0 copied to clipboard

A modern dependency injection like java spring package (adjusted for Dart 2.x)

0
likes
55 / 130
pub points
0 %
popularity

We analyzed this package on May 8, 2021, and awarded it 55 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 37 API elements (18.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:wired2/wired2.dart that imports:
  • package:mirrorme2/mirrorme2.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 35 issues. Showing the first 2:

INFO: Avoid const keyword.

lib/src/annotations/annotations.dart:3:19

  ╷
3 │ const Autowired = const _Autowired();
  │                   ^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/annotations/annotations.dart

INFO: Avoid const keyword.

lib/src/annotations/annotations.dart:11:14

   ╷
11 │ const Bean = const _Bean();
   │              ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/annotations/annotations.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
mirrorme2^0.1.00.1.00.1.0
path^1.6.21.8.01.8.0
yaml>=2.0.1+1 <3.0.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=2.0.1+1 <3.0.0` on yaml does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions yaml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
55
pub points
0%
popularity

A modern dependency injection like java spring package (adjusted for Dart 2.x)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ozonesurfer68@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

mirrorme2, path, yaml

More

Packages that depend on wired2