webview_flutter 3.0.4 icon indicating copy to clipboard operation
webview_flutter: ^3.0.4 copied to clipboard

A Flutter plugin that provides a WebView widget on Android and iOS.

2200
likes
120/ 130
pub points
100%
popularity

We analyzed this package 6 hours ago, and awarded it 120 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 61 out of 63 API elements (96.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_surface_android.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: The operand can't be null, so the condition is always true.

lib/src/webview.dart:99:31

   ╷
99 │   })  : assert(javascriptMode != null),
   │                               ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/webview.dart

INFO: The operand can't be null, so the condition is always true.

lib/src/webview.dart:100:43

    ╷
100 │         assert(initialMediaPlaybackPolicy != null),
    │                                           ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/webview.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
webview_flutter_android^2.8.02.8.82.8.8
webview_flutter_platform_interface^1.8.01.8.11.8.1
webview_flutter_wkwebview^2.7.02.7.52.7.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
collection-1.16.01.16.0
material_color_utilities-0.1.40.1.5
meta-1.7.01.7.0
path-1.8.11.8.1
plugin_platform_interface-2.1.22.1.2
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.