websocket_channel_wrapper 1.1.4
websocket_channel_wrapper: ^1.1.4 copied to clipboard

Wrapper for web_socket_channel package lightweight and isomorphic lib with socket.io-like event handling, Future-based requests.

4
likes
80/ 130
pub points
41%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/websocket_channel_wrapper_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 11 API elements (63.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:websocket_channel_wrapper/websocket_channel_wrapper.dart that imports:
  • package:websocket_channel_wrapper/src/websocket_channel_wrapper_base.dart that imports:
  • package:web_socket_channel/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/websocket_channel_wrapper_base.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
pedantic^1.0.01.11.11.11.1
web_socket_channel^1.0.141.2.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
collection-1.15.01.15.0
crypto-3.0.13.0.1
meta-1.7.01.7.0
stream_channel-2.1.02.1.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.14` on web_socket_channel does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions web_socket_channel to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

4
likes
80
pub points
41%
popularity

Wrapper for web_socket_channel package lightweight and isomorphic lib with socket.io-like event handling, Future-based requests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

pedantic, web_socket_channel

More

Packages that depend on websocket_channel_wrapper