webdriver 2.1.2
webdriver: ^2.1.2 copied to clipboard

Provides WebDriver bindings for Dart. Supports WebDriver JSON interface and W3C spec. Requires the use of WebDriver remote server.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  webdriver: ^2.1.2

2. Install it

You can install packages from the command line:

with pub:

$ dart pub get

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:webdriver/async_core.dart';
import 'package:webdriver/async_html.dart';
import 'package:webdriver/async_io.dart';
import 'package:webdriver/core.dart';
import 'package:webdriver/io.dart';
import 'package:webdriver/support/async.dart';
import 'package:webdriver/support/firefox_profile.dart';
import 'package:webdriver/support/forwarder.dart';
import 'package:webdriver/support/stdio_stepper.dart';
import 'package:webdriver/sync_core.dart';
import 'package:webdriver/sync_io.dart';
10
likes
70
pub points
96%
popularity

Publisher

google.dev

Provides WebDriver bindings for Dart. Supports WebDriver JSON interface and W3C spec. Requires the use of WebDriver remote server.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

archive, matcher, path, stack_trace, sync_http

More

Packages that depend on webdriver