webdev_proxy 0.1.2
webdev_proxy: ^0.1.2 copied to clipboard

A simple HTTP proxy for webdev's serve command. Supports apps that use HTML5 routing by rewriting 404s to the root index.

2
likes
80/ 130
pub points
4%
popularity

We analyzed this package on Nov 30, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.11.6.02.3.0
glob^1.1.71.2.02.0.2
http^0.12.00.12.20.13.4
http_multi_server^2.1.02.2.03.0.1
io^0.3.30.3.51.0.3
logging^0.11.3+20.11.41.0.2
meta>=1.1.7 <1.7.01.6.01.7.0
pedantic^1.7.01.11.11.11.1
pub_semver^1.4.21.4.42.1.0
shelf^0.7.20.7.91.2.0
shelf_proxy^0.1.00.1.0+71.0.1
stack_trace^1.9.31.10.01.10.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
file-5.2.16.1.2
http_parser-3.1.44.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
path-1.8.01.8.0
source_span-1.8.11.8.1
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 10 issues. Showing the first 2:

The constraint `^1.5.1` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^1.1.7` on glob does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions glob to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.11.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

2
likes
80
pub points
4%
popularity

Publisher

workiva.com

A simple HTTP proxy for webdev's serve command. Supports apps that use HTML5 routing by rewriting 404s to the root index.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

args, glob, http, http_multi_server, io, logging, meta, pedantic, pub_semver, shelf, shelf_proxy, stack_trace

More

Packages that depend on webdev_proxy