web_ffi 0.7.2 copy "web_ffi: ^0.7.2" to clipboard
web_ffi: ^0.7.2 copied to clipboard

Translates dart:ffi calls on the web to WebAssembly using dart:js

17
likes
130/ 160
pub points
84%
popularity

We analyzed this package 6 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

125 out of 142 API elements (88.0 %) have documentation comments.

Some symbols that are missing documentation: web_ffi.DoublePointer.operator []=, web_ffi.DynamicLibrary.boundMemory, web_ffi.DynamicLibraryExtension, web_ffi.FloatPointer.operator []=, web_ffi.Int8Pointer.operator []=.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 36 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/modules/module.dart:68:17

   ╷
68 │   bool operator ==(dynamic other) {
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/modules/module.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/modules/module.dart:101:17

    ╷
101 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/modules/module.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
js ^0.6.3 0.6.7 0.7.1
meta ^1.3.0 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.3` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.5, Dart 3.4.1.

Check the analysis log for details.

17
likes
130
pub points
84%
popularity

Publisher

verified publishereric-prokop-und-nils-wieler.de

Translates dart:ffi calls on the web to WebAssembly using dart:js

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

js, meta

More

Packages that depend on web_ffi