web_ffi 0.7.2 copy "web_ffi: ^0.7.2" to clipboard
web_ffi: ^0.7.2 copied to clipboard

Translates dart:ffi calls on the web to WebAssembly using dart:js

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add web_ffi

With Flutter:

 $ flutter pub add web_ffi

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  web_ffi: ^0.7.2

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:web_ffi/web_ffi.dart';
17
likes
130
pub points
84%
popularity

Publisher

verified publishereric-prokop-und-nils-wieler.de

Translates dart:ffi calls on the web to WebAssembly using dart:js

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

js, meta

More

Packages that depend on web_ffi