web_browser_detect 1.0.3 icon indicating copy to clipboard operation
web_browser_detect: ^1.0.3 copied to clipboard

Flutter Web browser detection package. This package allows you to detect which browser and its version is in use.

9
likes
80/ 130
pub points
92%
popularity

We analyzed this package 6 days ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 15 API elements (13.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/browser.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
universal_html^1.2.41.2.42.0.8
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
characters-1.2.01.2.1
charcode-1.3.11.3.1
collection-1.16.01.16.0
crypto-3.0.23.0.2
csslib-0.16.20.17.1
html-0.14.0+40.15.0
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
path-1.8.21.8.2
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
universal_io-2.0.42.0.4
vector_math-2.1.22.1.2
zone_local-0.1.20.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.2.4` on universal_html does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions universal_html to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.

9
likes
80
pub points
92%
popularity

Publisher

verified publisher icontomas-chyly.com

Flutter Web browser detection package. This package allows you to detect which browser and its version is in use.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, universal_html

More

Packages that depend on web_browser_detect