web3_contract 0.1.3 icon indicating copy to clipboard operation
web3_contract: ^0.1.3 copied to clipboard

Supporting code for generated dart classes corresponding to ABIs of Solidity smart contracts

2
likes
80/ 140
pub points
14%
popularity

We analyzed this package 16 hours ago, and awarded it 80 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 36 API elements (8.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:web3_contract/web3_contract.dart that imports:
  • package:web3_contract/src/transactions.dart that imports:
  • package:web3dart/web3dart.dart that imports:
  • package:isolate/isolate.dart that imports:
  • package:isolate/registry.dart that imports:
  • package:isolate/ports.dart that imports:
  • dart:isolate
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'package:web3dart/contracts.dart' is unnecessary because all of the used elements are also provided by the import of 'package:web3dart/web3dart.dart'.

lib/web3_contract.dart:3:8

  ╷
3 │ import 'package:web3dart/contracts.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/web3_contract.dart

INFO: The import of 'package:web3dart/credentials.dart' is unnecessary because all of the used elements are also provided by the import of 'package:web3dart/web3dart.dart'.

lib/web3_contract.dart:4:8

  ╷
4 │ import 'package:web3dart/credentials.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/web3_contract.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
logging^0.11.40.11.41.1.0
meta^1.2.31.8.01.8.0
web3dart^1.2.31.2.32.5.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
charcode-1.3.11.3.1
collection-1.17.01.17.0
convert-2.1.13.1.1
crypto-2.1.53.0.2
http-0.12.20.13.5
http_parser-3.1.44.0.2
isolate-2.1.12.1.1
json_rpc_2-2.2.23.0.2
path-1.8.21.8.2
pedantic-1.11.11.11.1
pointycastle-1.0.23.6.2
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stream_channel-2.1.12.1.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uuid-2.2.23.0.7

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^0.11.4 on logging does not support the stable version 1.0.0.

Try running dart pub upgrade --major-versions logging to update the constraint.

The constraint ^1.2.3 on web3dart does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions web3dart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.10.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

2
likes
80
pub points
14%
popularity

Publisher

verified publisher iconsecure.vote

Supporting code for generated dart classes corresponding to ABIs of Solidity smart contracts

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

logging, meta, web3dart

More

Packages that depend on web3_contract