web3_contract 0.1.3 icon indicating copy to clipboard operation
web3_contract: ^0.1.3 copied to clipboard

Supporting code for generated dart classes corresponding to ABIs of Solidity smart contracts

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add web3_contract

With Flutter:

 $ flutter pub add web3_contract

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  web3_contract: ^0.1.3

Alternatively, your editor might support dart pub get or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:web3_contract/web3_contract.dart';
2
likes
80
pub points
26%
popularity

Publisher

verified publisher iconsecure.vote

Supporting code for generated dart classes corresponding to ABIs of Solidity smart contracts

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

logging, meta, web3dart

More

Packages that depend on web3_contract