wa_me 0.0.7 copy "wa_me: ^0.0.7" to clipboard
wa_me: ^0.0.7 copied to clipboard

Simple way to share message, links or files from your flutter app to specific contact in whatsapp

5
likes
150/ 160
pub points
52%
popularity

We analyzed this package 25 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5 out of 11 API elements (45.5 %) have documentation comments.

Some symbols that are missing documentation: wa_me, wa_me.Package, wa_me.Package.Package, wa_me.Package.packageName, wa_me.WaMe.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:wa_me/wa_me.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:wa_me/wa_me.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:wa_me/wa_me.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:wa_me/wa_me.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

5
likes
150
pub points
52%
popularity

Publisher

verified publisheriamngoni.co.zw

Simple way to share message, links or files from your flutter app to specific contact in whatsapp

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on wa_me