voyager 2.1.2
voyager: ^2.1.2 copied to clipboard

Flutter Android iOS web

The widget router and basic dependency injection library for Flutter. Define navigation paths in YAML and power them up with custom plugins.

12
likes
80 / 110
pub points
66 %
popularity

We analyzed this package on Feb 24, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 150 API elements (14.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/router.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
provider>=4.0.0 <4.5.04.3.34.3.3
sprintf^4.0.24.1.05.0.0
yaml^2.1.162.2.13.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
meta-1.3.0-nullsafety.31.3.0
nested-0.0.41.0.0
path-1.7.01.8.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.2` on sprintf does not support the latest published version `5.0.0`

pubspec.yaml:13:12

   ╷
13 │   sprintf: ^4.0.2
   │            ^^^^^^
   ╵
The constraint `^2.1.16` on yaml does not support the latest published version `3.0.0`

pubspec.yaml:12:9

   ╷
12 │   yaml: ^2.1.16
   │         ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

12
likes
80
pub points
66%
popularity

Publisher

vishna.dev

The widget router and basic dependency injection library for Flutter. Define navigation paths in YAML and power them up with custom plugins.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, provider, sprintf, yaml

More

Packages that depend on voyager