volume_util 0.0.4 copy "volume_util: ^0.0.4" to clipboard
volume_util: ^0.0.4 copied to clipboard

A flutter plugin to config and monitor volume. Support Android and iOS platform.

2
likes
140/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

6 out of 13 API elements (46.2 %) have documentation comments.

Some symbols that are missing documentation: volume_util, volume_util.StreamType, volume_util.StreamType.StreamType, volume_util.ToAndroidStreamType, volume_util.ToAndroidStreamType.toStreamType.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:volume_util/volume_util.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:volume_util/volume_util.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:volume_util/volume_util.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:volume_util/volume_util.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
volume_util_android ^0.0.1 0.0.1 0.0.1
volume_util_ios ^0.0.2 0.0.2 0.0.2
volume_util_platform_interface ^0.0.5 0.0.5 0.0.5
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

2
likes
140
pub points
0%
popularity

Publisher

verified publisherzyzdev.dev

A flutter plugin to config and monitor volume. Support Android and iOS platform.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, volume_util_android, volume_util_ios, volume_util_platform_interface

More

Packages that depend on volume_util