vin_decoder 0.1.4+1
vin_decoder: ^0.1.4+1 copied to clipboard

Dart library for working with Vehicle Identification Numbers (VINs) based on ISO 3779:2009 and World Manufacturer Identifiers (WMIs) based on ISO 3780:2009, enriched by NHTSA data.

8
likes
100/ 130
pub points
82%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/vin_decoder_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 26 API elements (80.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
basic_utils^2.7.12.7.13.9.1
http^0.12.20.12.20.13.4
meta^1.4.01.7.01.7.0
random_string^2.1.02.3.12.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
http_parser-3.1.44.0.0
json_annotation-3.1.14.4.0
logging-0.11.41.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pointycastle-2.0.13.4.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.7.1` on basic_utils does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions basic_utils to update the constraint.

The constraint `^0.12.2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

8
likes
100
pub points
82%
popularity

Publisher

adaptant.io

Dart library for working with Vehicle Identification Numbers (VINs) based on ISO 3779:2009 and World Manufacturer Identifiers (WMIs) based on ISO 3780:2009, enriched by NHTSA data.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

basic_utils, http, meta, random_string

More

Packages that depend on vin_decoder