version_tracking 1.0.1+1
version_tracking: ^1.0.1+1 copied to clipboard

Flutter Android iOS macOS

Xamarin.Essentials VersionTracking for Flutter.

1
likes
75 / 110
pub points
51 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:29:49

   ╷
29 │ <p>Please file feature requests and bugs at the <a href="http://github.com/jamiewest/version_tracking/issues">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 14 out of 17 API elements (82.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:version_tracking/version_tracking.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: Avoid empty statements.

lib/version_tracking.dart:30:74

   ╷
30 │     Map<String, List<String>> versionTrail = Map<String, List<String>>();;
   │                                                                          ^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/version_tracking.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/version_tracking.dart:36:23

   ╷
36 │         _versionsKey: List<String>(), 
   │                       ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/version_tracking.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
package_info^0.4.0+50.4.3+42.0.0
shared_preferences^0.5.3+40.5.12+42.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.1.04.1.0
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.02.0.0
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0+5` on package_info does not support the stable version `2.0.0`, that was published 12 days ago.

When package_info is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions package_info to update the constraint.

The constraint `^0.5.3+4` on shared_preferences does not support the stable version `2.0.0`, that was published 9 days ago.

When shared_preferences is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions shared_preferences to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

1
likes
75
pub points
51%
popularity

Publisher

jamiewest.dev

Xamarin.Essentials VersionTracking for Flutter.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, package_info, shared_preferences

More

Packages that depend on version_tracking