vaycore 1.0.1 icon indicating copy to clipboard operation
vaycore: ^1.0.1 copied to clipboard

A flutter application development library, which integrates some modules commonly used in daily development projects, makes developing applications more convenient.

1
likes
70/ 140
pub points
0%
popularity

We analyzed this package 30 hours ago, and awarded it 70 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
10 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/xhvay/vaycore_sample was unreachable. Make sure that the website is reachable via HEAD requests.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 191 out of 377 API elements (50.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:vaycore/vaycore.dart that imports:
  • package:vaycore/utils.dart that imports:
  • package:vaycore/src/utils/toast_utils.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:vaycore/vaycore.dart that imports:
  • package:vaycore/utils.dart that imports:
  • package:vaycore/src/utils/toast_utils.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:vaycore/vaycore.dart that imports:
  • package:vaycore/utils.dart that imports:
  • package:vaycore/src/utils/toast_utils.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:vaycore/vaycore.dart that imports:
  • package:vaycore/utils.dart that imports:
  • package:vaycore/src/utils/app_utils.dart that imports:
  • package:package_info/package_info.dart that declares support for platforms: Android, iOS, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:vaycore/vaycore.dart that imports:
  • package:vaycore/utils.dart that imports:
  • package:vaycore/src/utils/path_utils.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:vaycore/vaycore.dart that imports:
  • package:vaycore/utils.dart that imports:
  • package:vaycore/src/utils/path_utils.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: The import of 'package:vaycore/src/modules/locale/vc_locale_delegate.dart' is unnecessary because all of the used elements are also provided by the import of 'package:vaycore/modules.dart'.

lib/src/common/base_app.dart:12:8

   ╷
12 │ import 'package:vaycore/src/modules/locale/vc_locale_delegate.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/common/base_app.dart

INFO: The import of 'dart:ui' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/rendering.dart'.

lib/src/common/screen_adapter.dart:12:8

   ╷
12 │ import 'dart:ui';
   │        ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/common/screen_adapter.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^3.0.93.0.104.0.6
flutterflutter0.0.00.0.0
flutter_localizationsflutter0.0.00.0.0
fluttertoast^4.0.14.0.18.1.2
package_info^0.4.10.4.3+42.0.2
path_provider^1.6.71.6.282.0.12
provider^4.1.14.3.36.0.5
shared_preferences^0.5.7+10.5.12+42.0.17
sprintf^4.0.24.1.07.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
clock-1.1.11.1.1
collection-1.17.01.17.1
ffi-1.2.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.2
intl-0.17.00.18.0
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
nested-1.0.01.0.0
path-1.8.21.8.3
path_provider_linux-0.0.1+22.1.7
path_provider_macos-0.0.4+82.0.7
path_provider_platform_interface-1.0.42.0.5
path_provider_windows-0.0.52.1.3
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.3
process-4.2.44.2.4
shared_preferences_linux-0.0.2+42.1.3
shared_preferences_macos-0.0.1+112.0.5
shared_preferences_platform_interface-1.0.42.1.0
shared_preferences_web-0.1.2+72.0.4
shared_preferences_windows-0.0.2+32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4
win32-2.6.14.1.1
xdg_directories-0.1.20.2.0+3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^3.0.9` on dio does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^4.0.1` on fluttertoast does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions fluttertoast to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

1
likes
70
pub points
0%
popularity

Publisher

unverified uploader

A flutter application development library, which integrates some modules commonly used in daily development projects, makes developing applications more convenient.

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

dio, flutter, flutter_localizations, fluttertoast, package_info, path_provider, provider, shared_preferences, sprintf

More

Packages that depend on vaycore