url_preview_card 0.2.1 copy "url_preview_card: ^0.2.1" to clipboard
url_preview_card: ^0.2.1 copied to clipboard

Flutter package to show url preview. Cache newwork response.

7
likes
40/ 160
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 40 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.3. Cannot run `flutter pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.3.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.4.3)

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/20 points: Compatible with dependency constraint lower bounds

flutter pub downgrade failed with:

OUT:
Resolving dependencies...
ERR:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.

The current Dart SDK (3.4.3) only supports null safety.

For details, see https://dart.dev/null-safety

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.