upnp_port_forward 1.0.8 copy "upnp_port_forward: ^1.0.8" to clipboard
upnp_port_forward: ^1.0.8 copied to clipboard

upnp port forward daemon

1
likes
90/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 30 API elements (3.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: soap, soap.Protocol, soap.Protocol.Protocol, soap.Soap, soap.Soap.Soap.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:upnp_port_forward/init.dart that imports:
  • package:intranet_ip/intranet_ip.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: This function has a nullable return type of 'FutureOr

lib/soap.dart:63:15

   ╷
63 │ Future<Soap?> controlUrl(String url) async {
   │               ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/soap.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
await_sleep ^1.0.1 1.0.1 1.0.1
collection ^1.15.0 1.18.0 1.18.0
intranet_ip ^1.0.2 1.0.2 1.0.2
random_uint8list ^1.0.0 1.0.2 1.0.2
req ^1.0.2 1.0.3 1.0.3
rmwlog ^1.0.2 1.0.10 1.0.10
try_catch ^1.0.2 1.0.2 1.0.2
xml ^5.3.0 5.4.1 6.5.0
Transitive dependencies
Package Constraint Compatible Latest
colorize - 3.0.0 3.0.0
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
petitparser - 5.4.0 6.0.2
stack_trace - 1.11.1 1.11.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.3.0` on xml does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions xml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.