union_pay 1.0.1
union_pay: ^1.0.1 copied to clipboard

A Flutter plugin for allowing developers to pay with native Android&iOS UnionPay SDKs.

2
likes
95/ 130
pub points
13%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 95 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 23 API elements (17.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:union_pay/union_pay.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/enum/union_pay_enum.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/model/payment_result_model.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

2
likes
95
pub points
13%
popularity

A Flutter plugin for allowing developers to pay with native Android&iOS UnionPay SDKs.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on union_pay