unifi 0.1.17 copy "unifi: ^0.1.17" to clipboard
unifi: ^0.1.17 copied to clipboard

A Dart implementation that provides access to Unifi Controllers API 6.x and later.

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 18 hours ago, and awarded it 100 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

12 out of 56 API elements (21.4 %) have documentation comments.

Some symbols that are missing documentation: guests, guests.Guests, guests.Guests.Guests, guests.Guests.dispose, guests.GuestsExtension.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:unifi/unifi.dart that imports:
  • package:unifi/src/controller.dart that imports:
  • package:unifi/src/websocket.dart that imports:
  • package:unifi/src/session.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

WARNING: Unused import: 'dart:developer'.

lib/src/session.dart:3:8

  ╷
3 │ import 'dart:developer';
  │        ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/session.dart

WARNING: Unused import: 'package:web_socket_channel/web_socket_channel.dart'.

lib/src/session.dart:6:8

  ╷
6 │ import 'package:web_socket_channel/web_socket_channel.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/session.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.3 2.0.5 2.0.5
http ^0.13.1 0.13.6 1.2.1
json_annotation ^4.0.0 4.9.0 4.9.0
logging ^1.0.1 1.2.0 1.2.0
path ^1.8.0 1.9.0 1.9.0
rxdart ^0.27.2 0.27.7 0.27.7
web_socket_channel ^2.1.0 2.4.5 2.4.5
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
http_parser - 4.0.2 4.0.2
meta - 1.14.0 1.14.0
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.1` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

0
likes
100
pub points
0%
popularity

Publisher

verified publisherkacao.dev

A Dart implementation that provides access to Unifi Controllers API 6.x and later.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, http, json_annotation, logging, path, rxdart, web_socket_channel

More

Packages that depend on unifi