uigitdev_request_holder 1.3.2 icon indicating copy to clipboard operation
uigitdev_request_holder: ^1.3.2 copied to clipboard

A ready-made structure that holds HTTP requests and helps to ensure reusability and reduce the number of lines of code.

3
likes
140/ 140
pub points
32%
popularity

We analyzed this package 11 hours ago, and awarded it 140 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Unlicense.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 64 API elements (31.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
http ^0.13.5 0.13.6 1.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.17.1 1.17.2
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.6.7
material_color_utilities - 0.2.0 0.5.0
meta - 1.9.1 1.9.1
path - 1.8.3 1.8.3
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`, that was published 14 days ago.

When http is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Dart 3 & Flutter 3.10 compatibility
20 / 20icon to trigger folding of the section

20/20 points: Package is Dart 3 & Flutter 3.10 compatible!

Analysed with Pana 0.21.32, Flutter 3.10.2, Dart 3.0.2.

3
likes
140
pub points
32%
popularity

Publisher

verified publisher iconuigitdev.com

A ready-made structure that holds HTTP requests and helps to ensure reusability and reduce the number of lines of code.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Unlicense (LICENSE)

Dependencies

flutter, http

More

Packages that depend on uigitdev_request_holder