uic 0.8.0
uic: ^0.8.0 copied to clipboard

A set of Flutter UI components that simplifies implementing most used UI cases.

68
likes
100/ 130
pub points
63%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 122 out of 257 API elements (47.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
provider^4.0.04.3.36.0.1
url_launcher^5.4.25.7.106.0.12
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
nested-1.0.01.0.0
plugin_platform_interface-1.0.32.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
url_launcher_linux-0.0.1+42.0.2
url_launcher_macos-0.0.1+92.0.2
url_launcher_platform_interface-1.0.92.0.4
url_launcher_web-0.1.5+32.0.4
url_launcher_windows-0.0.1+32.0.2
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on provider does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions provider to update the constraint.

The constraint `^5.4.2` on url_launcher does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions url_launcher to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

68
likes
100
pub points
63%
popularity

Publisher

eche.dev

A set of Flutter UI components that simplifies implementing most used UI cases.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, provider, url_launcher

More

Packages that depend on uic