ucsb_gold 0.0.1
ucsb_gold: ^0.0.1 copied to clipboard

A flutter package for UCSB Gold API.

0
likes
50 / 130
pub points
0 %
popularity

We analyzed this package on May 8, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 43 API elements (11.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:ucsb_gold/ucsb_gold.dart that imports:
  • package:ucsb_gold/parse.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: Unused import: 'dart:io'.

lib/parse.dart:2:8

  ╷
2 │ import 'dart:io';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/parse.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/parse.dart:7:28

  ╷
7 │   schedule['course'] = new List();
  │                            ^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/parse.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
html^0.14.0+20.14.0+40.15.0
http^0.12.0+20.12.20.13.3
logger^0.7.0+20.7.0+21.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
csslib-0.16.20.17.0
http_parser-3.1.44.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.14.0+2` on html does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions html to update the constraint.

The constraint `^0.12.0+2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

0
likes
50
pub points
0%
popularity

A flutter package for UCSB Gold API.

Homepage

Documentation

API reference

Uploader

luyiping1011@gmail.com

License

LGPL 3.0 (LICENSE)

Dependencies

flutter, html, http, logger

More

Packages that depend on ucsb_gold