txconnect 1.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 55

An Unoffical API for txConnect SCUC.

Usage #

A simple usage example:

import 'package:txconnect/txconnect.dart';

main() {
  var tx = TxConnect();
}

Features #

Basic features including attendance, grades and classes, and alerts.

Expansion #

Post an issue if you would like to expand this project to multiple districts.

1.0.0 #

  • Initial version. Basic features including attendance, grades and classes, and alerts.

1.0.1 #

  • Made dio and cookieJar private.

1.0.2 #

  • Added alert parser.

1.0.3 #

  • Refactor alert parser.

example/txconnect_example.dart

import 'package:txconnect/txconnect.dart';

void main(List<String> args) async {
  var tx = TxConnect();
  //Switch with your username and password
  print(await tx.login('username', 'password'));
  print(await tx.getStudents());
  print(await tx.switchStudent('00'));
  print(await tx.getClassrooms());
  print(await tx.getGrades('02'));
  print(await tx.getAttendance());
  print(await tx.getAlerts(true));
  // await tx.readAlert('13');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  txconnect: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:txconnect/txconnect.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because:

  • package:txconnect/txconnect.dart that imports:
  • package:txconnect/src/txconnect_dio_base.dart that imports:
  • package:cookie_jar/cookie_jar.dart that imports:
  • package:cookie_jar/src/serializable_cookie.dart that imports:
  • dart:io

Package not compatible with runtime js

Because:

  • package:txconnect/txconnect.dart that imports:
  • package:txconnect/src/txconnect_dio_base.dart that imports:
  • package:cookie_jar/cookie_jar.dart that imports:
  • package:cookie_jar/src/serializable_cookie.dart that imports:
  • dart:io

Health issues and suggestions

Document public APIs. (-0.63 points)

78 out of 79 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
cookie_jar ^1.0.0 1.0.1
dio ^3.0.9 3.0.9
dio_cookie_manager ^1.0.0 1.0.0
html ^0.14.0+3 0.14.0+3
http ^0.12.1 0.12.1
Transitive dependencies
charcode 1.1.3
collection 1.14.13 1.15.0-nullsafety
csslib 0.16.1
http_parser 3.1.4
meta 1.2.2 1.3.0-nullsafety
path 1.7.0
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0 1.3.0-nullsafety
Dev dependencies
pedantic ^1.8.0 1.9.2
test ^1.6.0