twitter_login_v2 0.0.3 copy "twitter_login_v2: ^0.0.3" to clipboard
twitter_login_v2: ^0.0.3 copied to clipboard

Flutter Twitter Login Plugin. Library for login with Twitter Oauth V2.

5
likes
120/ 140
pub points
61%
popularity

We analyzed this package 6 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

7 out of 24 API elements (29.2 %) have documentation comments.

Some symbols that are missing documentation: access_token_v2, access_token_v2.AccessTokenV2.accessToken, access_token_v2.AccessTokenV2.expiresIn, access_token_v2.AccessTokenV2.getAccessToken, access_token_v2.AccessTokenV2.scope.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:twitter_login_v2/twitter_login_v2.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:twitter_login_v2/twitter_login_v2.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:twitter_login_v2/twitter_login_v2.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:twitter_login_v2/twitter_login_v2.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

INFO: Use 'isEmpty' instead of 'length' to test whether the collection is empty.

lib/schemes/authorization_code_v2.dart:99:9

   ╷
99 │     if (scopeUrl.length == 0)
   │         ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/schemes/authorization_code_v2.dart

INFO: Statements in an if should be enclosed in a block.

lib/schemes/authorization_code_v2.dart:100:7

    ╷
100 │       throw new NoValidScopeSpecified();
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/schemes/authorization_code_v2.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
crypto ^3.0.1 3.0.3 3.0.3
flutter flutter 0.0.0 0.0.0
http ^0.13.3 0.13.6 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

5
likes
120
pub points
61%
popularity

Publisher

verified publisheranycloud.co.jp

Flutter Twitter Login Plugin. Library for login with Twitter Oauth V2.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

crypto, flutter, http

More

Packages that depend on twitter_login_v2