twitter_auth 0.0.4 icon indicating copy to clipboard operation
twitter_auth: ^0.0.4 copied to clipboard

A Flutter plugin to sign in with Twitter on Android & iOS.

2
likes
90/ 140
pub points
24%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 21 API elements (42.9 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:twitter_auth/twitter_auth.dart that imports:
  • package:twitter_auth/src/twitter_auth.dart that imports:
  • package:twitter_auth/src/utils/exception.dart that imports:
  • package:flutter_auth_core/flutter_auth_core.dart that imports:
  • package:flutter_auth_core/src/utils/flutter_auth_webview.dart that imports:
  • package:flutter_webview_plugin/flutter_webview_plugin.dart that declares support for platforms: Android, iOS.

Package does not support platform Linux.

Because:

  • package:twitter_auth/twitter_auth.dart that imports:
  • package:twitter_auth/src/twitter_auth.dart that imports:
  • package:twitter_auth/src/utils/exception.dart that imports:
  • package:flutter_auth_core/flutter_auth_core.dart that imports:
  • package:flutter_auth_core/src/utils/flutter_auth_webview.dart that imports:
  • package:flutter_webview_plugin/flutter_webview_plugin.dart that declares support for platforms: Android, iOS.

Package does not support platform macOS.

Because:

  • package:twitter_auth/twitter_auth.dart that imports:
  • package:twitter_auth/src/twitter_auth.dart that imports:
  • package:twitter_auth/src/utils/exception.dart that imports:
  • package:flutter_auth_core/flutter_auth_core.dart that imports:
  • package:flutter_auth_core/src/utils/flutter_auth_webview.dart that imports:
  • package:flutter_webview_plugin/flutter_webview_plugin.dart that declares support for platforms: Android, iOS.

Package does not support platform Web.

Because:

  • package:twitter_auth/twitter_auth.dart that imports:
  • package:twitter_auth/src/twitter_auth.dart that imports:
  • package:twitter_auth/src/utils/exception.dart that imports:
  • package:flutter_auth_core/flutter_auth_core.dart that imports:
  • package:flutter_auth_core/src/utils/flutter_auth_webview.dart that imports:
  • package:flutter_webview_plugin/flutter_webview_plugin.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'package:meta/meta.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/src/twitter_auth.dart:5:8

  ╷
5 │ import 'package:meta/meta.dart' show required, visibleForTesting;
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/twitter_auth.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_auth_core^0.0.00.0.40.0.4
http^0.12.20.12.20.13.5
meta^1.1.81.8.01.8.0
oauth1^1.0.41.0.62.0.0
quiver>=2.0.0 <3.0.02.1.53.1.0
xml_parser^0.1.20.1.21.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.16.01.17.0
convert-2.1.13.1.1
crypto-2.1.53.0.2
flutter_web_plugins-0.0.00.0.0
flutter_webview_plugin-0.3.110.4.0
html_character_entities-0.1.2+41.0.0+1
http_parser-3.1.44.0.2
js-0.6.40.6.5
matcher-0.12.130.12.13
material_color_utilities-0.1.50.2.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
plugin_platform_interface-1.0.32.1.3
recursive_regex-0.1.3+21.0.0
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
url_launcher-5.7.106.1.7
url_launcher_linux-0.0.1+43.0.1
url_launcher_macos-0.0.1+93.0.1
url_launcher_platform_interface-1.0.92.1.1
url_launcher_web-0.1.5+32.0.13
url_launcher_windows-0.0.1+33.0.1
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint ^0.12.2 on http does not support the stable version 0.13.0.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint ^1.0.4 on oauth1 does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions oauth1 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

2
likes
90
pub points
24%
popularity

Publisher

verified publisher iconstacktiger.dev

A Flutter plugin to sign in with Twitter on Android & iOS.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

flutter, flutter_auth_core, http, meta, oauth1, quiver, xml_parser

More

Packages that depend on twitter_auth