trober_sdk 0.0.55 copy "trober_sdk: ^0.0.55" to clipboard
trober_sdk: ^0.0.55 copied to clipboard

The trober SDK

0
likes
90/ 140
pub points
26%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

124 out of 454 API elements (27.3 %) have documentation comments.

Some symbols that are missing documentation: trober_sdk, trober_sdk.ApiKeyAuthInterceptor, trober_sdk.ApiKeyAuthInterceptor.ApiKeyAuthInterceptor, trober_sdk.ApiKeyAuthInterceptor.apiKeys, trober_sdk.AppInfo.minVersion.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 28 issues. Showing the first 2:

WARNING: Unused import: 'package:trober_sdk/src/model/error.dart'.

lib/src/api/default_api.dart:17:8

   ╷
17 │ import 'package:trober_sdk/src/model/error.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/api/default_api.dart

lib/src/api.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
built_collection >=5.1.0 <6.0.0 5.1.1 5.1.1
built_value >=8.1.0 <9.0.0 8.9.2 8.9.2
dio >=4.0.1 <5.0.0 4.0.6 5.4.3+1
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
fixnum - 1.1.0 1.1.0
http_parser - 4.0.2 4.0.2
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=4.0.1 <5.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.