treebuildermvc 0.0.2
treebuildermvc: ^0.0.2 copied to clipboard

A new Flutter package project.

0
likes
60 / 130
pub points
0 %
popularity

We analyzed this package on Jul 30, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 19 out of 529 API elements (3.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 16 issues. Showing the first 2:

lib/builder.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/codegenerator/generator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build_runnerany2.0.62.0.6
code_builderany4.1.04.1.0
cupertino_icons^0.1.20.1.31.0.3
flutterflutter0.0.00.0.0
quickexpressionany1.0.51.0.5
source_genany1.0.31.0.5
xmlany5.1.25.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.023.0.0
analyzer-1.7.12.0.0
args-2.2.02.2.0
async-2.8.12.8.1
build-2.0.32.0.3
build_config-1.0.01.0.0
build_daemon-3.0.03.0.0
build_resolvers-2.0.42.0.4
build_runner_core-7.0.17.0.1
built_collection-5.1.05.1.0
built_value-8.1.18.1.1
characters-1.1.01.1.0
charcode-1.3.11.3.1
checked_yaml-2.0.12.0.1
cli_util-0.3.30.3.3
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-2.0.32.0.3
file-6.1.26.1.2
fixnum-1.0.01.0.0
frontend_server_client-2.1.02.1.0
glob-2.0.12.0.1
graphs-2.0.02.0.0
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
io-1.0.31.0.3
js-0.6.30.6.3
json_annotation-4.0.14.1.0
logging-1.0.11.0.1
matcher-0.12.100.12.10
meta-1.3.01.7.0
mime-1.0.01.0.0
package_config-2.0.02.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
petitparser-4.1.04.2.0
pool-1.5.01.5.0
pub_semver-2.0.02.0.0
pubspec_parse-1.0.01.0.0
shelf-1.2.01.2.0
shelf_web_socket-1.0.11.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timing-1.0.01.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
watcher-1.0.01.0.0
web_socket_channel-2.1.02.1.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.2` on cupertino_icons does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions cupertino_icons to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.